with init7 releasing their new tiers fiber7-x (10gbits sym.) and fiber7-x2 (25gbits sym.), they have updated their router recommendations with the MikroTik CCR2004-1G-12S +2XS and even though it has disappointed some people with its lack of features, performance and weird bugs.

i still decided to go for it as it is cheaper for me than building a proper home-made router in a 1u case that supports 10 and 25gbit/s.

okay, so enough talking. even though the circle of people who still watch tv and are into homelabbing/work in it probably doesn’t meet at all. here’s my short guide on how to set it up.

requirements:

  • a mikrotik router with routeros
  • fiber7 connection
  • being able to restart your connection

first off, we need to get the extra package from the mikrotik website. you can find it under https://mikrotik.com/download.
download the extra package for your architecture (if you’ve got a mikrotik router, it’s arm64) with the fitting version.
if you don’t know which version of routeros you have, you can see it on top of your winbox taskbar or check it on your router’s webfig interface on the login screen.

you can extract the extra packages onto a temporary folder and select the “multicast” package. now in order to install extra packages onto your router, you need to have access to it per winbox or per its webinterface.
select the “files” button and drag and drop (or upload if you want) the package onto the files screen.

setting up tv7 on your mikrotik router

the next step is to restart your router.

to make sure our package is installed and enabled, you can go and check it under “system > packages”

cli users:
1
/system package print

if it isn’t enabled, you can enable it by pressing the “enable” button

cli users:
1
/system package enable multicast

now we get onto configuring the igmp proxy.
we can first go onto “routing > igmp proxy” and we should be on the interface tab.

the first interface we’re configuring is the wan side.
as the interface, we choose our interface that is connected to the fiber7 line. (in this case sfp-sfpplus1)
we can keep our threshold at 1 and we need to add the alternative subnet “0.0.0.0/0”, what’s important is that we check the upstream tickbox for the wan side.

setting up tv7 on your mikrotik router
cli users:
1
2
/routing igmp-proxy interface add interface=sfp-sfpplus1 threshold=1 upstream=yes alternative
-subnets=0.0.0.0/0

now the second interface we’re configuring is the one where your device lies that is gonna utilize the tv7 service.
in my case, i’m gonna be watching it with my computer which is connected to the ether1 interface.
we can set our threshold to 2 and we should be done for this side.

setting up tv7 on your mikrotik router
cli users:
1
/routing igmp-proxy interface add interface=ether1 threshold=2 upstream=no

if you’ve got a rule that is blocking every type of traffic from the input side, we need to add a rule allowing our igmp traffic through.
it needs to be setup like this:

setting up tv7 on your mikrotik router
cli users:
1
/ip firewall filter add chain=input action=accept protocol=udp src-address=0.0.0.0/0 dst-address=239.0.0.0/8 log=no log-prefix=""

that was it. you should be able to enjoy your TV service that is provided by init7.

setting up tv7 on your mikrotik router

thank you for reading this article. if you’ve got any suggestions or improvements, please make a comment. i do not offer support for this. this is not an official tutorial by init7.